How to disable/hide a specific modality

This procedure would disable/hide a specific modality to show up in the image viewer for ResolutionMD

Details:

Below are the basic steps that will disable specific modality to show up.

  1. SSH to the server with a user that has root permission.
  2. Execute: vim /opt/CSI/PureWeb/Server/conf/dicomqr-plugin.xml
    or winscp to the server and edit the dicomqr-plugin.xml
  3. Uncomment the following:
    <!--property name="seriesFilters"> 

    <list> 

    <bean class="pureweb.plugins.dicomqr.SeriesModalityFilter"> 

    <property name="excludedModalityList"> 

    <list> 

    <value>KO</value> 

    <value>PS</value> 

    <value>PR</value> 

    <value>GSPS</value> 

    </list> 

    </property> 

    </bean> 

    </list> 

    </property-->

     

    • Change it to:
      <!-- The following propperty is used for Series Modality Filtering-->

      <property name="seriesFilters"> 

      <list> 

      <bean class="pureweb.plugins.dicomqr.SeriesModalityFilter"> 

      <property name="excludedModalityList"> 

      <list> 

      <value>[Enter specific Modality here]</value> 

      </list> 

      </property> 

      </bean> 

      </list> 

      </property>

       

      • Save the file and execute: service pureweb restart

      Common Problems: 

      • Due to some archive/PACS configurations not returning specific information as part of the C-FIND results, the modality may not be hidden.
      • The modality may not be supported.  Ensure the modality is a supported DICOM standard.
      • THe XML file may not be properly set.  Ensure the following:
        • !-- is removed from:  <!--property name="seriesFilters">
        • -- is removed from:  </property-->
        • Ensure the default <value> parameters are removed and replaced with what should be hidden.
        • The changes did not apply.  Ensure the pureweb service is restarted.

      The below example will filter to exclude/disable the OT modality.
      1. SSH to the server with a user that has root permission.
      2. Execute: vim /opt/CSI/PureWeb/Server/conf/dicomqr-plugin.xml
      3. Uncomment the following:
      <!--property name="seriesFilters"> 

      <list> 

      <bean class="pureweb.plugins.dicomqr.SeriesModalityFilter"> 

      <property name="excludedModalityList"> 

      <list> 

      <value>KO</value> 

      <value>PS</value> 

      <value>PR</value> 

      <value>GSPS</value> 

      </list> 

      </property> 

      </bean> 

      </list> 

      </property-->

       

      4. Change it to:
      <!-- The following propperty is used for Series Modality Filtering-->

      <property name="seriesFilters"> 

      <list> 

      <bean class="pureweb.plugins.dicomqr.SeriesModalityFilter"> 

      <property name="excludedModalityList"> 

      <list> 

      <value>OT</value> 

      </list> 

      </property> 

      </bean> 

      </list> 

      </property>
      5. Save the file and execute: service pureweb restart